Enabling 32 bit adressing

2 replies [Last post]
Offline
Joined: 04/14/2004

Hey, I need to enable 32 bit adressing to play 7th guest (or so the game says), yet I don't see that option in my memory control panel. I'm running MAC OS 9.0.4. Can anyone point me to the place to do this?

Offline
Joined: 02/12/2009

32 bit addressing is built into the Mac OS. This happened back in the days of OS 7. Back then, as developers transitioned their apps to be "32 bit clean," the Memory Control Panel had an option to turn 32 bit on/off. This would only show up in that control panel if you had a Mac model which needed this option. I don't know if it shows up in later OSes like OS 9.

Here are a few links to learn more:

http://www.lowendmac.com/trouble/32bit.shtml
https://en.wikipedia.org/wiki/Mac_OS_history

Or try this app, Mode32 (I thought this was just for OS 7, though):
http://download.info.apple.com/Apple_Support_Area/Apple_Software_Updates/English-North_American/Macintosh/System/Other_System/MODE32_7.5.txt

http://download.info.apple.com/Apple_Support_Area/Apple_Software_Updates/English-North_American/Macintosh/System/Other_System/MODE32_7.5.sea.bin

(Side note: there was a 32-bit Enabler extension provided with System 7.1.)

n/a
Offline
Joined: 04/14/2004

Yeah it turned out that it was a virtual memory problem, not 32 bit enabling. It fixed itself, although in the process it erased quicktime :P

Anyways, everything''s reinstalled now, and thanks again. Good game, by the way, a bit disturbed, but very addictive

Share this