my XT20 does not turn on - reinitializing doesn't work

1 reply [Last post]
Offline
Joined: 09/28/2004

I recently aquired this used XT20. It was working fine, but I started getting some interpolation messages on certain parts of the BASF tape I was recording to, so I got a dry tapehead cleaner and ran it through. When I played back the tape the interpolation asterisk did not light up.

The tape was still playing when I plugged my mixer into the same power strip that the xt20 was plugged into, which was not grounded.
When I looked up, the main LED displayed nothing. I power cycled it and all I got was the transport buttons flashing -- no main LED. I tried reinitializing but it didn't work, then I moved the adat to a grounded outlet and tried again -- it still didn't work, but when I powered it up about an hour later, the main display was working, and I was able to rewind the tape before it shut off again.

Again reinitializing did nothing. When I tried it again the next morning, it worked and I was able to take the tape out. That was the last time the display came on. I've since tried to use it several times, but all it does is blink those transport buttons. Does this sound repairable? Any ideas/suggestions would be greatly appreciated.
Thanks!

Offline
Joined: 02/12/2009

Ouch, it sounds like it's time to get a professional repair person's opinion. Paying for a pro's opinion is worth way more than a doorstop! In the San Francisco Bay Area, here are some repair places:
http://www.silentway.com/node/1126

If you are located elsewhere, contact Alesis (it looks like they no longer take out-of-warranty gear, but maybe they can advise):
http://alesis.com/contact/tech.html

n/a
Share this